wiki:WikiStart

Version 27 (modified by dallura, 5 years ago) (diff)

--

AVISU (Arianet VISUalizer) - Manuale utente Versione 1.8

Convenzioni

<AVISU_DIR> la directory di installazione del package AVISU. Valore di default C:\ADSOPC\AVISU

<VNI> è la directory di installazione di PV-WAVE. Valore di default C:\VNI

<project> sub-directory di <AVISU_DIR>, dedicata ai files relativi al progetto con nome “project”

<project>.ini file di configurazione principale della directory <project>

<config> file di configurazione salvato in una directory di progetto; simbologia usata per indicare genericamente sia il file di configurazione principale che secondari

File nome di un comando di menù oppure nome di un campo dell’interfaccia utente

File => Save Config nome di un comando di sotto-menù dell’interfaccia utente

1.Introduzione

2. Per iniziare

3.Lavorare con AVISU

4. Comandi del menù principale

5. Utilizzo di AVISU in modalità batch

A partire dalla versione 1.2, è possibile utilizzare AVISU per produrre in modo automatico delle sequenze di bitmap. Per fare questo devono essere effettuate le operazioni seguenti

  • preparare un nuovo progetto
  • utilizzare la procedura AVISUB.BAT con parametro da linea di comando “project”.

5.1 Preparazione del progetto

Per la generazione di bitmap può essere utilizzato un progetto già esistente o creato appositamente. In ogni caso, come prima cosa, occorre aprire AVISU, caricare <project> e il file di configurazione di default <project>.ini.

Attraverso l’interfaccia grafica, devono essere eseguite poi le operazioni seguenti:

  1. Caricamento del file GRID (Par. 3.2.1)
  2. scelta della variabile di cui si vogliono ottenere le bitmap (Par. 3.3)
  3. scelta del tipo di sezione (Par. 3.5.1), se la variabile è 3D
  4. scelta della coordinata di estrazione (Par. 3.5.2) , se la variabile è 3D
  5. impostazione del tipo di grafico (Par. 3.6)

Utilizzando il menù di Export (Par. 4.8):

  1. impostare la tipologia di bitmap
  2. la risoluzione in pixel (modificabile anche con la finestra di Animate, Par. 4.9):
  3. la directory di salvataggio dei files
  4. uscire, senza esportare alcuna immagine

Se si vuole esportare una sequenza limitata di immagini, occorre definire gli estremi della sequenza da produrre. Per far questo si deve utilizzare il menù di Animate :

  1. per esportare tutte le sequenze, è sufficiente cliccare sul pulsante Reset e uscire con Cancel;
  1. altrimenti agire sulla sequenza di inizio e di fine, selezionare il periodo ed eseguire l’animazione come descritto al Par.4.9. In questo modo vengono memorizzati il numero di scadenza di inizio e di fine della sequenza da esportare.

Utilizzando il menù di File => Save Config (Par. 4.1.10), salvare il file di configurazione.

5.2 Lancio della procedura AVISUB

Dopo aver preparato il progetto come descritto al paragrafo precedente, andare nella directory <AVISU_DIR> ed eseguire la procedura di comandi AVISUB.BAT.

Si apre una finestra DOS che mostra la lista dei progetti presenti in <AVISU_DIR>, seguita dalla richiesta del nome del progetto: digitare il nome “project” e poi <Invio>. Dopo aver fornito il nome del progetto, viene chiesto il nome della variabile da graficare: come valore di default viene proposta l’ultima variabile utilizzata con il progetto scelto.

A_figura152.jpg

Figura 76 - Finestra avvio AVISUB

Dopo la digitazione della variabile, parte AVISU e viene eseguita una sessione di tipo Animate e subito dopo l’esportazione delle immagini: nella stessa finestra inizieranno a scorrere una serie di messaggi che notificano la creazione dei files.

A_figura153.jpg

Figura 77 - Finestra log AVISUB

In alternativa alla modalità interattiva la stessa procedura può essere lanciata da una finestra DOS già aperta fornendo i comandi:

cd <AVISU_DIR>

AVISUB.BAT project

Oppure:

AVISUB.BAT project variable

Per interrompere la procedura premere i tasti <Ctrl-C> .

6. Descrizione dei file

Questo capitolo è dedicato alla descrizione dei formati e contenuti file di Input /Output di AVISU.

Sono Input essenzialmente i file dati dell’utente che vengono importati per la visualizzazione.

A questi si aggiungono altri file di Input nella directory di installazione di AVISU <AVISU_DIR>, i file di configurazione del package.

Nella directory di progetto si trovano invece i file di lavoro, che possono essere sia di Input che Output di AVISU, i file di log, generati ad ogni caricamento di file GRID e PARTIC, e file di statistiche, scritti da AVISU ogniqualvolta viene eseguito un nuovo grafico.

6.1 File Dati

Sono considerati file dati i seguenti:

  • file GRID
  • file PARTIC
  • file CARTOG

L’utente ne effettua il caricamento attraverso una finestra che consente l’apertura del file. La loro posizione può essere quindi qualsiasi e non si conoscono restrizioni né sul nome del file né sulla lunghezza del percorso ad essi relativi.

Il nome completo di questi file è memorizzato nel file di configurazione del progetto.

6.1.1 File GRID

Il file GRID è un file binario e contiene, in ordine di scadenza temporale, una serie di campi scalari sotto forma di matrici bi- e/o tri-dimensionali con dati relativi ad una grandezza meteorologica o chimica che varia nello spazio.

A partire dalla versione1.3.3, AVISU è in grado di importare sia files in formato ADSOBINbinario che files in formato NetCDF3 con convenzione COARDS. Dalla versione 1.5.6 è stata implementata la lettura di NetCDF con convenzione CF.

Solo nel caso file di formato ADSOBIN, è possibile distinguere inoltre il tipo di codifica con cui sono stati scritti i valori numerici:

3 Il format ADSOBIN è il formato proprietario ARIA Technologies ed è utilizzato nei codici MINERVE, SPRAY, HERMES, MERCURE, ARIA Impact. Il formato NetCDF è un formato che aderisce allo standard della libreria NetCDF versione 2.3 ed è utilizzato per gli output di codici ARIANET quali FARM, SURFPRO, SLICER, ecc.

Big Endian – piattaforme UNIX (sun, solaris, sgi, rs6000)

Little Endian - piattaforme INTEL (linux e i386nt)

La scelta del tipo di codifica viene effettuata mediante il comando Options => Little Endian : se selezionato, vale la codifica Little Endian, altrimenti Big Endian.

In ogni file GRID possono essere memorizzati una o più matrici di campi scalari, tutti aventi le medesime caratteristiche geometriche: le matrici i cui dati, qui genericamente indicati con A[i,j,k], corrispondono ad un grigliato tridimensionale che è una discretizzazione del dominio di calcolo. Facendo riferimento allo schema di Figura 4, il grigliato è definito come segue:

  1. Per quanto riguarda le componenti orizzontali X e Y, il dominio di calcolo risulta discretizzato in celle regolari: entrambi gli assi coordinati, sono suddivisi in intervalli

equispaziati di passo fisso, chiamato DXY. Ne risulta quindi che, nel piano XY, il grigliato è regolare ed equispaziato e gli indici di cella i e j del dato A[i,j,k], identificano un punto che ha coordinate X e Y date da:

X[i,j,k] = (i-1) * DXY + XSW

Y[i,j,k] = (j-1) * DXY + YSW

Con: i=1,…, NX NX=numero di celle nella direzione X
     j=1,…, NY NY=numero di celle nella direzione Y
     k=Indice di livello verticale

     XSW=Coordinata X dell’angolo inferiore sinistro
         del dominio di calcolo

     YSW=Coordinata Y dell’angolo inferiore sinistro 
         del dominio di calcolo

Questo vale per ogni cella identificata dagli indici [i,j,k]. Ne consegue che, per ogni livello k, il grigliato XY è lo stesso, ossia identico al variare del livello.

  1. Per ciò che concerne la componente verticale Z, la discretizzazione dell’asse a cui corrispondono i livelli k, può essere di due tipi:
  • Spaziatura SIGMA, o ‘terrain-following’, in cui i livelli tendono ad essere compressi sui rilievi orografici.
  • Spaziatura DELTA-ZETA, con livelli di spaziatura costante sopra l’orografia

In entrambi i casi devono essere note le altezze di riferimento dei livelli rispetto al suolo e l’altezza dell’ultimo livello considerato il top del dominio, indicato con ZTOP, e che è un valore unico per tutto il grigliato dei dati.

Nel primo caso, nel sistema di coordinate verticali SIGMA, le altezze di riferimento si indicano con S, e sono riportate in un vettore di valori assoluti crescenti tra 0. e 1., mentre ZTOP è pari ad una quota in metri riferita al livello del mare, in genere dell’ordine di grandezza delle migliaia.

Per ogni cella del dominio tridimensionale identificata da [i,j,k] si ha che:

Z[i,j,k] = S[k] * (ZTOP-ZGROUND[i,j]) + ZGROUND[i,j]

con: S[k] = livello sigma k-esimo

K=1,…, NZ NZ=numero di livelli nella direzione Z

ZGROUND[i,j] = altezza dell’orografia nel punto di coordinate X[i,j,k], Y[i,j,k]

In particolare quando S[k]=0 è Z[i,j,k]= ZGROUND[i,j], mentre con S[NZ]=1 è Z[i,j,k]=ZTOP. Dato che spesso S(1)=0, AVISU considera per l’impostazione dei valori di default, il secondo livello, la cui altezza effettiva è al di sopra del suolo.

Dalla definizione data di Z[i,j,k] si deduce anche che, quando k=NZ i punti di grigliato hanno la medesima coordinata Z, per cui si dice che il top del dominio in coordinate sigma è piatto, al contrario di quanto accade al primo livello dove i punti di grigliato giacciono sull’orografia. Ai livelli intermedi, tenendo fisso k, l’altezza Z[i,j,k] varia al variare degli indici i e j, e lo spessore del livello sarà tanto minore quanto elevata è l’orografia sottostante.

Nel secondo caso, nel sistema di coordinate verticali DELTA-ZETA, le altezze di riferimento sono livelli dati da DZ/ZTOP, e costituiscono un vettore di valori crescenti che rappresentano lo spessore del grigliato a partire dal suolo fino all’altezza ZTOP, in questo caso al di sopra dell’orografia.

Per ogni cella del dominio tridimensionale identificata da [i,j,k] si ha che:

Z[i,j,k] = DZ[k] * ZTOP + ZGROUND[i,j]

con: DZ[k] = livello delta-zeta k-esimo

     K=1,…, NZ   NZ=numero di livelli 
                    nella direzione Z
     ZGROUND[i,j] = altezza dell’orografia 
                    nel punto di coordinate X[i,j,k], Y[i,j,k]

AVISU è in grado di determinare in modo automatico la tipologia di grigliato verticale. Di conseguenza l’utente non deve necessariamente conoscere questa informazione per visualizzare graficamente in modo corretto i dati dei campi 3D.

In particolare, per discriminare il grigliato, viene utilizzato il nome di modello scritto nel file GRID caricato. Viene considerato di tipo DELTA-ZETA se il nome appartiene alla lista seguente: CALMET, CALGRID, STEM, TURBANTZ, FARM, FARMZ, SURFPROZ, MINERVEZ. In tutti gli altri casi il grigliato viene considerato di tipo SIGMA.

Un modo pratico di conoscere il tipo di grigliato del file GRID caricato è quello di visualizzare una qualsiasi sezione verticale (Par. 3.5.1), selezionare la modalità di rappresentazione grafica ZETA (Par. 3.6.3) e cliccare suA_figura122.jpgnell’area di controllo superiore. In questo modo, al grafico dell’area grafica principale, verrà sovrapposto la traccia del grigliato dei dati: se i livelli verticali sono di tipo SIGMA, le curve dei livelli verticali sono più fitti in prossimità dei rilievi orografici e tendono ad appiattirsi all’aumentare della quota sino a diventare orizzontali in corrispondenza della fine dell’asse verticale; se i livelli verticali sono di tipo DELTA-ZETA, le curve dei livelli verticali corrono paralleli al di sopra dell’orografia e l’ultimo livello non ha altezza costante come invece avviene nel caso precedente.

6.1.2 File PARTIC

Il file PARTIC è un file in formato binario, output del codice SPRAY e contiene, in ordine di scadenza temporale, le coordinate delle particelle generate dal modello oltre alle informazioni di massa, specie, sorgente ed età ad esse associate.

E’ un file binario con organizzazione di tipo sequenziale a record di lunghezza fissa. Consiste in una sequenza di record di intestazione contenenti le informazioni necessarie per l’accesso diretto ai diversi frame di dati da cui il file risulta costituito. Ognuno di questi frame contiene le coordinate di particelle relative all’origine del dominio della simulazione (fornito in un record intestazione), la massa trasportata dalla particella per ogni specie emessa, il suo tempo di vita a partire dall’istante di emissione e l’identificativo della sorgente che l’ha emessa.

Per maggiori dettagli sul formato e contenuto si rimanda al manuale del codice SPRAY.

Anche per questo file vale la selezione relativa al tipo di codifica binaria Big/ Little Endian come per il file GRID, formato ADSOBIN.

6.1.3 File CARTOG

Il file CARTOG è un file in formato ASCII in cui sono memorizzate le descrizioni cartografiche relative ad un sito, secondo le tipologie poligoni (aree), curva e punti.

Si tratta, diversamente dai due precedenti, di un file di tipo vettoriale, nel senso che ogni figura è descritta da una coppia di vettori di coordinate X e Y che, per poter permettere la sovrapposizione grafica, devono essere nello stesso sistema di riferimento del file GRID.

Il formato generale è il seguente:

"PNAME 1"  "SNAME 1"   lunghezza
x1  y1
x2  y2
...
xn  yn
"PNAME 2"   "SNAME 2"   lunghezza
x1  y1
x2  y2
...
xn  yn

... ecc.

Ogni elemento cartografico è identificato da una riga di intestazione, contenente PNAME, SNAME, lunghezza, e da una serie di record, contenenti coppie di coordinate Xi Yi ,il cui numero dipende da lunghezza.

Significato dei campi:

  • PNAME nome identificativo primario (ad esempio: Coasts, Towns, Roads, ecc. ). Viene usato da AVISU per identificare il colore da associare all’elemento cartografico e quindi deve corrispondere ad una etichetta nel file color_cartog.dat (Par. 6.3).
  • SNAME nome identificativo secondario. È opzionale e viene considerato nullo se la stringa è vuota oppure pari a UNK (ad esempio “” oppure “UNK”) . Viene utilizzato per scrivere un titolo accanto all’elemento cartografico, con i tipi punto e area.
  • lunghezza è un intero il cui valore assoluto corrisponde al numero di punti dell’elemento cartografico e le cui coordinate sono riportate nelle righe successive. Il segno di questo numero determina la tipologia di elemento:

lunghezza<1, indica che l’elemento cartografico è una LINEA e non deve essere riempita di colore; la linea risulterà chiusa se primo e ultimo punto coincidono;

lunghezza=1, indica che l’elemento cartografico è un PUNTO;

lunghezza>1, indica che l’elemento cartografico è un’AREA chiusa e può essere riempita di colore se, in corrispondenza del tipo PNAME, è attivo il flag di riempimento nel file color_cartog.dat (Par. 6.3): se il flag di riempimento è attivo, verrà prodotta un’area chiusa congiungendo il primo e l’ultimo dei punti definiti, mentre, se non è attivo, la linea verrà plottata come nel caso di lunghezza<1, perciò sarà chiusa se e solo se il primo e l’ultimo punto coincidono.

  • Xi Yi costituiscono la coppia i-esima di coordinate dell’elemento cartografico

Nota: Il PNAME non identifica una tipologia ma solo una classe di elementi che saranno caratterizzati dallo stesso colore, dimensione del tratto e del carattere. La tipologia CURVA, PUNTO, AREA risulta definita solo dal parametro lunghezza.

Dalla versione 1.5 sono state introdotte alcune flessibilità tra cui la possibilità di dare file cartografici con coordinate espresse in m o km (Par. 4.2.5) e con diverse tipologie di separatori, per cui sono ritenute forme valide anche righe in cui i valori sono separati dai caratteri virgola (,) e punto-virgola (;) e non più solo dal carattere spazio ( ); inoltre, limitatamente alla sola intestazione, è possibile aggiungere in coda qualsiasi stringa [….] senza incorrere in errori di lettura.

Sono ad esempio considerati validi:

1) “PNAME” ”SNAME” -5 ; strada comunale
     464.217 , 5087.436
     464.235 , 5087.420
     464.736 , 5087.022
     465.180 , 5086.977
     465.799 , 5087.615 
2) “PNAME”;”SNAME”;n 
3) “”, ””, n  [….]
4) “”; “testo”; n  [….]

In assenza di PNAME, AVISU assegna il valore simbolico NOCLASS.

In assenza di SNAME, AVISU assegna il valore simbolico UNK.

Attenzione: i campi PNAME e SNAME devono essere sempre stringhe delimitate dal carattere doppio apice (“). Se lunghezza=0, oppure il numero delle coppie di coordinate non è pari al valore assoluto di lunghezza, il file non viene caricato .

6.2 File di impostazioni

A questo tipo di file, corrispondono i files installati nella directory principale <AVISU_DIR> ed i file di configurazione <config> che risiedono in ogni cartella <project> ed hanno estensione .ini, come il file <project>.ini, file di configurazione principale.

I file che al momento dell’installazione vengono copiati in <AVISU_DIR> e che sono necessari per il corretto funzionamento di AVISU sono riportati in tabella Tabella 7.

avisu1.cprCodice AVISU in linguaggio Pv-Wave, eseguibile solo tramite una procedura di lancio
avisu1.batProcedura di lancio di avisu1.cpr, modalità interattiva grafica
avisub.batProcedura di lancio di avisu1.cpr, modalità batch, non interattiva
avisu.chmFile di aiuto
stampanti.datFile di definizione delle stampanti, viene letto all’inizio
avisu.adParametri di risorse del GUI, viene letto solo all’inizio
avisupal.rgbPalette dei colori di AVISU, viene letto solo all’inizio.
color_ranges.datFile di default della tabella dei colori per file GRID, viene utilizzato quando si crea un nuovo progetto
color_partic.datFile di default della tabella dei colori per file PARTIC, viene utilizzato quando si crea un nuovo progetto
color_cartog.datFile di default della tabella dei colori per file CARTOG, viene utilizzato quando si crea un nuovo progetto

Tabella 7 - Elenco file installati di default

In Figura 78 è riportata la palette dei colori che corrisponde al file binario avisupal.rgb.

Nei paragrafi successivi, verranno fornite descrizioni dei files ASCII più significativi e che l’utente potrebbe avere necessità di modificare interattivamente.

A_figura154.jpg

Figura 78 - Palette dei colori di AVISU

6.2.1 File avisu.ad

Il file contiene valori utilizzati come impostazioni dell’interfaccia utente e di conseguenza non sono considerati nell’utilizzo batch di AVISU (Cap. 5). Inoltre, poiché ogni variabile prevede un valore di default, l’assenza del file o di una o più impostazioni non pregiudica il regolare funzionamento di AVISU.

Nel riquadro è riportato il contenuto del file incluso nella cartella di installazione:

*font: Arial, 8
*basecolor: grey70
*background: grey70
*foreground: midnightblue
*arrow_thick: 1.
*arrow_angle: 30
*arrow_length: 0.25
*block_flag:1
*surfer mirror: 0
  • font: font utilizzato per la scrittura dei widget; default=Arial,8
  • basecolor: colore di sfondo delle finestre generate dal GUI; default=black
  • background: colore di background dei widget; default= grey70
  • foreground: colore di foreground dei widget (scritte, label, numeri); default=midnightblue
  • arrow_thick: spessore delle frecce plottate come WIND FIELD nell’area grafica principale; default=1.0
  • arrow_angle: angolo di inclinazione delle punte delle frecce; default=45
  • arrow_length: lunghezza delle punte delle frecce; default=0.3
  • block_flag: plottaggio dei valori fuori scala nella visualizzazione 2D di tipo Filled Blocks (Par. 0)

-2 plot dei valori minori dei livello minimo e maggiori del livello massimo

-1 plot dei valori minori del livello minimo (no valori massimi)

0 nè valori minori del livello minimo né maggiori del livello massimo

1 plot dei valori maggiori del livello massimo (no valori minimi)

2 come -2

default=1

  • surfer mirror: ribalta l’ordine di scrittura della matrice dati nell’esportazione SURFER; 1 rovescia la y in modo da avere la 1° riga =NORD; default=0 (1° riga=SUD)

6.2.2 File stampanti.dat

Nel riquadro è riportato il contenuto del file incluso nell’installazione:

A_figura155.jpg

Il formato di tale file è fisso e in caso di modifica occorre rispettare le convenzioni di scrittura: la prima e la terza riga sono commenti, non interpretati da AVISU, le restanti righe sono lette e hanno il significato seguente:

1° riga: commento

2° riga: numero di stampanti da utilizzare; 5 significa che solo le prime 5 definite verranno usate da AVISU

3° riga: commento

4° riga e successive: ogni riga corrisponde alla definizione di una stampante, che può essere reale (stampa diretta) o fittizia (stampa su file). Le stampanti definite sono: le prime due sono utilizzabili solo su piattaforma Windows, mentre le ultime 2 righe riportano l’esempio di due definizioni per stampanti HP, utilizzabili su piattaforma Linux.

Descrizione dei campi:

- nella prima colonna è riportata la label (25 caratteri) che verrà visualizzata da AVISU per la selezione della stampante,

- nella seconda il nome della coda di stampa (15 caratteri, solo per Linux/ Unix),

- nella terza il tipo di linguaggio utilizzato per produrre il grafico (6 caratteri). I tipi previsti sono: WPR=stampante Windows diretta, WMF=file in formato wmf, PS o PSL=Postscript a colori verticale, PSP= Postscript a colori orizzontale, PSBW=Postscript in bianco e nero, EPS= Encapsulated Postscript a colori

- nella quarta il comando di stampa che deve essere eseguito per inviare il grafico direttamente alla stampante (20 caratteri, solo Linux/ Unix).

- nella quinta colonna un commento di lunghezza qualsiasi

6.2.3 File di configurazione principale <project>.ini

Il file <project>.ini viene scritto automaticamente da AVISU all’interno della cartella <project> ed è utilizzato per la memorizzazione dei nomi file e delle impostazioni del GUI. Viene caricato ogniqualvolta si carica il progetto con le funzioni di File => Project (Par.4.1.6) e salvato quando il progetto viene cambiato o all’uscita dal programma con File => Exit.

E’ un file in formato ASCII che, per ogni riga, presenta una coppia chiave-valore scritta come assegnazione:

chiave=valore

L’esempio, riportato in Figura 79, mostra il file del progetto NOVARA, scritto da AVISU: le chiavi sono raggruppate per sezioni.

------------------- Files --------------------------------
MODINP= C:\adsopc\AVISU\novara
MODOUT= C:\DATI\NOVARA
MODOUTPARTIC= 
FILINP=novara_19079915.bin
PARINP=
CARTOG=C:\DATI\NOVARA\Novara_prova.bna	
SFONDO=C:\ADSOPC\AVISU\Novara\arianova1.jpg
DIRIMG=C:\TEMP\
------------------- Flags --------------------------------
TIPEND=LITTLE
DEBUG=OFF
MSGLVL=0
JOURNAL=OFF
INFORMA=OFF
MOUSE=OFF
READBIN=OFF
SHOROG=ON
SHCARTO=ON
SHBITMA=OFF
SHGRID=OFF
SHPARTI=OFF
INTERP=OFF
CARTUND=OFF
OROGUND=OFF
WINDSCA=OFF
CONTOUR=1
------------------- Slice --------------------------------
VARNAME=PHI
X_TRANS=509
Y_TRANS=5089
Z_TRANS=91.2703
S_TRANS=0.2873
CURR_DATA_TYPE=2
CURR_VAR_2D=0
CURR_VAR_3D=0
CURR_VEC_COL=0
CURR_SLICE=2
ISEQMET=0
ISEQPAR0=0
ISEQPAR1=0
-------------------- GUI ---------------------------------
SIGMA_OR_Z=1
CONT_FILLBL=1
POINTER_ACT=1
ARROW_MS_U=5
ARROW_MS_V=5
ARROW_MS_W=0.25
ARROW_FACTU=1
ARROW_FACTV=2
ARROW_FACTW=1
EXPORT_TYPE=2
EXPORT_PIXEL=700
EXPORT_TITLE=OFF
ANIM_INI=0
ANIM_END=24
ANIM_MEM=OFF
STARTACTION=0
CARTOG_FACTOR=1
SAVE_TOPTITLE=ON
TOPTITLE=media %AVG
-------------------- END ---------------------------------

Figura 79 – Esempio di file di configurazione <progetto>.ini In fase di lettura AVISU, considera solo le righe che contengono assegnazioni delle chiavi, cioè che contengono il carattere uguale (=), saltando tutte le altre. Non è necessario che le assegnazioni rispettino l’ordine dell’esempio o che siano tutte presenti perché sono previsti valori di default per tutte le chiavi. Se fosse necessario, vengono invece considerate righe di commento, quelle che iniziano con carattere punto esclamativo (!).

Ogni file <config> presente nella cartella <project>, salvato con File => Save Config as …, ha questo stesso formato. Inoltre una copia dell’ultimo <config> caricato nella sessione di lavoro interattiva di VAISU viene salvato automaticamente nel file <AVISU_DIR>\avisu1.ini per permettere, al successivo rilancio di AVISU, di caricare automaticamente l’ultimo progetto utilizzato.

Oltre alle chiavi scritte da AVISU, mostrate nell’esempio di Figura 79, questo file ne può contenere altre che corrispondono ad impostazioni del GUI che non vengono salvate da AVISU nel file <project>.ini.

Queste possono essere editate direttamente nel file per impostare dei valori di default e sono utili ad AVISU lanciato in modalità batch (Par. 5.2):

ALIASNAMEnome variabile da utilizzare nel graficoAlias Name, Par.4.2.1, pagina 59
ALIASUNITunità di misuraAlias Unit, Par. 4.2.1, pagina 60
FACTORfattore per conversione lineareFactor, Par. 4.2.5, pagina 73
OFFSEToffset per conversione lineareOffset, Par. 4.2.5, pagina 73

Tabella 8 - Chiavi opzionali del file configurazione <progetto>.ini, non scritte da AVISU

6.3 File di lavoro

Questo insieme di file è contenuto nella directory del progetto selezionato <project> e riguarda essenzialmente i colori usati per i grafici. Inizialmente, quando il progetto è nuovo, vengono copiati da <AVISU_DIR> e, in seguito, vengono modificati con le funzioni apposite del menù di Options. Per tutti vale la palette di riferimento a 256 colori di Figura 78.

6.3.1 File color_ranges.dat

In questo file sono riportati i codici colori per le variabili 2D e 3D dei file binari GRID. Il file è modificabile con la funzione Options => Modify Grid Colors (Par. 4.2.1).

Il file è in fomato ASCII e riporta una sequenza di color-table ognuna corrispondente ad una variabile 2D o 3D. Il blocco dati che descrive la color-table contiene le seguenti informazioni:

  1. 1 record con nome e numero di colori della color-table, corrispondente al numero di righe successive (N). Il nome è quello di una variabile del file GRID. Il numero N deve essere minore o uguale a 20;
  1. N records, contenenti valore minimo, massimo e codice di colore di una classe. Il codice fa riferimento alla Figura 70. AVISU non effettua nessun controllo che le classi siano contigue o distinte, per cui occorre fare molta attenzione alle eventuali modifiche effettuate con programmi di editing.

Questo file in genere viene incrementato da AVISU nel corso delle sessioni di lavoro a causa del fatto che file provenienti da modelli o simulazioni diverse contengono variabili con nomi che non trovano riscontro in questo file: in questo caso avviene la creazione di una nuova color-table con parametri standard: se il campo ha valore minimo e massimo nulli, 2 classi di colore la prima bianca e l’altra nera; in caso contrario, 20 classi scalate automaticamente fra minimo e massimo con range di colore fra 130, il minimo, e 64, il massimo. Ogni color-table creata viene salvata in memoria e ne viene richiesto il salvataggio solo all’uscita dal progetto o da AVISU.

Nella Figura 80 è riportato un esempio, estratto da un file che contiene le variabili REL e USOL: per la prima variabile sono previste 12 classi di colori, per la seconda 20.

                 REL          12
       566.1070       874.2340     16
       874.2340       1182.360     16
       1182.361       1490.488     17
       1490.488       1798.615     18
       1798.615       2106.742     19
       2106.742       2414.869     20
       2414.869       2722.996     21
       2722.996       3031.123     22
       3031.123       3339.250     23
       3339.250       3647.377     24
       3647.377       3955.504     25
       3955.504       4263.631     26
                USOL          20
      -6.995295      -6.369273     10
      -6.369273      -5.743251     20
      -5.743251      -5.117229     30
      -5.117229      -4.491208     40
      -4.491208      -3.865186     50
      -3.865186      -3.239164     60
      -3.239164      -2.613142     70
      -2.613142      -1.987121     80
      -1.987121      -1.361099     90
      -1.361099     -0.7350769    100
     -0.7350769     -0.1090555    110
     -0.1090555      0.5169663    120
      0.5169663       1.142988    130
       1.142988       1.769010    140
       1.769010       2.395032    150
       2.395032       3.021053    160
       3.021053       3.647075    170
       3.647075       4.273097    180
       4.273097       4.899118    190
       4.899118       5.525141    201

Figura 80 – Esempio di files color_ranges.dat

6.3.2 File color_partic.dat

In questo file sono riportati i codici colori per la colorazione delle particelle dei file binari PARTICLE.

Il file è modificabile con la funzione Options => Modify Particle Colors (Par.4.2.2).

Il formato e il contenuto sono analoghi a quelli di color_ranges.dat, la sola differenza consiste nei nomi delle variabili. In questo caso esistono dei nomi standard (SIGMA, ZETA,SOURCE, AGE) che non sono legati a variabili del file PARTIC e che l’utente è bene non modifichi con l’editor (Figura 81).

               SIGMA          10
       0.000000     0.05000000      2
     0.05000000      0.1000000      3
      0.1000000      0.1500000      4
      0.1500000      0.2000000      5
      0.2000000      0.2500000      6
      0.2500000      0.3000000      7
      0.3000000      0.3500000     25
      0.3500000      0.6000000     47
      0.8000000      0.9000000     12
      0.9000000       1.000000     13
                ZETA           8
       0.000000       150.0000     48
       150.0000       300.0000     49
       300.0000       450.0000      4
       450.0000       600.0000      5
       600.0000       750.0000      6
       750.0000       900.0000      7
       900.0000       1050.000     25
       1050.000       1200.000     47
              SOURCE           2
       0.000000       85.00000      4
       85.00000       100.0000      2
                 AGE          10
       0.000000       360.0000     79
       360.0000       720.0000     84
       720.0000       1080.000     89
       1080.000       1440.000     95
       1440.000       1800.000    100
       1800.000       2160.000    106
       2160.000       2520.000    111
       2520.000       2880.000    117
       2880.000       3240.000    122
       3240.000       3600.000    128

Figura 81 – Esempio di files color_partic.dat

6.3.3 File color_cartog.dat

In questo file sono riportati i codici per la rappresentazione dei files cartografici.

Il file è modificabile con la funzione Options => Modify Cartography (Par. 4.2.4). Un esempio è riportato in Figura 82.

      20
       Coasts    1    1    0  1.000  2.000 !20b
    PolBounds    1    1    0  1.000  2.000 !20b
        Urban    2    1    1  1.000  2.000 !20b
     Glaciers   30    1    1  1.000  2.000 !20b
        Roads    4    1    0  1.000  2.000 !20b
        Rails   27    1    0  1.000  2.000 !20b
    WaterArea   59    1    1  1.000  2.000 !20b
       Rivers   59    1    0  1.000  2.000 !20b
       Bounds    9    1    0  1.000  2.000 !20b
        Towns   10    1    0  1.000  2.000 !20b
        Città   10    1    0  1.000  2.000 !20b
     Airports   11    1    0  1.000  2.000 !20b
   AreeUrbane   12    1    0  1.000  2.000 !20b
   Autostrade   13    1    0  1.000  2.000 !20b
StradeStatali   13    1    0  1.000  2.000 !20b
       Comuni   14    1    0  1.000  2.000 !20b
     Province   15    1    0  1.000  2.000 !20b
  AreaSources   16    1    0  1.000  2.000 !20b
 PointSources   17    1    0  1.000  2.000 !20b
  LineSources   18    1    0  1.000  2.000 !20b 
 UNCLASSIFIED    1    1    0  1.000  2.000 !20b

Figura 82 – Esempio di file color_cartog.dat

1° riga: numero di elementi cartografici che seguono: corrisponde al numero di righe successive ad esclusione dell’ultima denominata UNCLASSIFIED.

2° riga e successive: ogni riga corrisponde alla definizione di un elemento cartografico. I campi descrittivi sono 6 e devono essere separati da almeno un spazio vuoto.

  1. etichetta identificativa di una classe cartografica, corrispondente ad uno dei tipi PNAME riportati nel file CARTOG;
  2. indice di colore nella tabella dei colori di riferimento di AVISU;
  3. flag di utilizzo (1) o esclusione (0) della classe dal plottaggio;
  4. indice di riempimento (1=riempie). Valido solo per gli elementi di CARTOG di tipo AREA;
  5. dimensione della linea o del carattere (opzionale);
  6. codifica del tipo di carattere (opzionale).

L’ultima riga è dedicata alle caratteristiche di plottaggio di tutti gli elementi cartografici il cui PNAME non è uguale a una delle classi precedenti.

1.1 File di log

I file di log sono generati all’interno della directory di progetto durante la creazione dei grafici.

- grid.log

- partic.log

6.3.4 File grid.log

File generato ogniqualvolta viene letto un nuovo file di tipo GRID (File => Open Grid File …)

Il contenuto riporta le informazioni relative al grigliato tridimensionale, i livelli verticali e le scadenze temporali memorizzate nel file. Il file è consultabile da interfaccia grafica mediante la funzione File => View Grid Log File.

*********** 14/12/2009 11:55 ****************

E:\xSKYNET\Valbelluna\OUTPUT\FORECAST\OUTPUT\conc.bin
Binary File format = LITTLE ENDIAN
 

--- NETCDF file ---
netCDF ID & conventions     :  0 COARDS
first deadline              :    2   12 2009    1    0    0
last deadline               :    3   12 2009    1    0    0
deadlines frequency (s)     :   1 hour(s)
# of deadlines              :    25 (    25 actually filled with data)
Model name                  :
# of gridpoints (x, y, z)   :  67  68  12
grid cell sizes (x, y)      :        1.000        1.000
coord. of SW corner (metric):      705.000     5083.000
coord. of SW corner (geo)   :  -999.000000  -999.000000
top of the domain           :  6353.522
levels                      :  10.00000  32.00000  62.00000  105.0000  180.0000
                               305.0000  505.0000  805.0000  1230.000  1805.000
                               2555.000  3480.000 (m)
# of variables (2D, 3D)     :  15   2
2D variables                : REL c_CO c_SO2 c_ISOP c_C6H6 c_NO c_NO2 c_NH3 c_NOx 
                              c_ANO3 c_ANH4 c_AORG c_APNAT c_PM25 c_PM10
3D variables                : PHI c_O3

--- Deadlines list (actually filled with data):
#   1: 02/12/2009 h 01:00:00
#   2: 02/12/2009 h 02:00:00
#   3: 02/12/2009 h 03:00:00
#   4: 02/12/2009 h 04:00:00
#   5: 02/12/2009 h 05:00:00
#   6: 02/12/2009 h 06:00:00
#   7: 02/12/2009 h 07:00:00
#   8: 02/12/2009 h 08:00:00
#   9: 02/12/2009 h 09:00:00
#  10: 02/12/2009 h 10:00:00
#  11: 02/12/2009 h 11:00:00
#  12: 02/12/2009 h 12:00:00

Figura 83 – Esempio di file grid.log

6.3.5 File partic.log

File generato ogniqualvolta viene letto un nuovo file di tipo PARTIC (File => `Open Partic File …`).

*********** 13/02/2003 10:19 ****************

Binary File format = LITTLE ENDIAN
 
C:\SIMAGETA\CATENA4\OUTPUT\spray3part_catena4_TA.bin
 
Number of sources =           6
Number of species =           5
Number of photos  =          10
SW corner coord. =       655.000       4460.00
NE corner coord. =       725.000       4525.00
Source number        1 Name PTS1.    
Source number        2 Name PTS2.    
Source number        3 Name PTS3.    
Source number        4 Name PTS4.    
Source number        5 Name PTS5.    
Source number        6 Name PTS6.    
Specie number        1 Name CO      
Specie number        2 Name DUST    
Specie number        3 Name NOX     
Specie number        4 Name SO2     
Specie number        5 Name HCl     
 
---------------------------------------------------------------------------
   Photo              Date               Number of particle  
---------------------------------------------------------------------------
        001 |    021007120000   |      103955
        002 |    021007130000   |      101510
        003 |    021007140000   |      101355
        004 |    021007150000   |      102057
        005 |    021007160000   |       87694
        006 |    021007170000   |       76962
        007 |    021007180000   |       73090
        008 |    021007190000   |       72242
        009 |    021007200000   |       68334
        010 |    021007210000   |       65112

Figura 84 – Esempio di file partic.log

Il contenuto del file descrive i limiti spaziali del dominio interessato dalle particelle, il numero di specie il numero di sorgenti trattate e le scadenze temporali memorizzate nel file. Il file è consultabile da interfaccia grafica mediante la funzione File => View Particle Log File.

6.4 File di statistiche

I file di statistiche vengono generati ogniqualvolta viene prodotto un grafico e si trovano nella directory di progetto.

I nomi assunti per i files sono prefissati e corrispondono al tipo di sezione effettuata:

- statistic_NN.log    NN=XY, YZ, XZ, 2D
- particle_NN.log     NN=XY, YZ, XZ
- statistic_DIAGONAL.log

Questi file vengono utilizzati nella visualizzazione dati fatta con Image Info del menù contestuale (Par. 2.4.2).

6.4.1 File di tipo statistic_NN.LOG

Questo tipo di file viene generato ogniqualvolta viene richiesto un grafico che aggiorna l’area grafica principale o uno Zoom (solo statistic_XY.log).

Il file riporta una statistica di sintesi dei dati usati per il grafico:

- numero di dati totali e validi

- minimo massimo e 50° percentile (mediana)

- valor medio e deviazione standard.

-------------------------------------------------------------------------------
FILE: E:\xSKYNET\ARPABR-new\OUTPUT\FORECAST\OUTPUT\surfpro.bin
TIME SEQUENCE:     18/09/2009  23:00:00     
WIND FIELD: SPEED - S=0.002307, 13.842 m
-------------------------------------------------------------------------------
Total Number of data:        324.000
Number of valid data:        324.000
Minimum,50^ percentile,maximum :        2.16413       2.49194       2.91449
Mean and standard deviation    :       2.51329      0.179464
-------------------------------------------------------------------------------

Figura 85 - Statistiche di una sezione orizzontale XZ di un campo3D, coordinata S costante

-------------------------------------------------------------------------------
FILE: C:\SIMAGEPU\CATENA1\OUTPUT\conc_CATENA1_PU.bin
TIME SEQUENCE:     07/04/2004  15:00:00     
3D SCALAR FIELD: c_CO - X=650
-------------------------------------------------------------------------------
Total Number of data:        612.000
Number of valid data:        612.000
Minimum,50^ percentile,maximum :        50.8630       165.530       212.766
Mean and standard deviation    :       152.653       33.0837
-------------------------------------------------------------------------------

Figura 86 - Statistiche di una sezione verticale YZ di un campo3D, coordinata X costante

-------------------------------------------------------------------------------
FILE: C:\SIMAGEPU\CATENA1\OUTPUT\conc_CATENA1_PU.bin
TIME SEQUENCE:     07/04/2004  15:00:00     
3D SCALAR FIELD: c_CO - Y=4525
-------------------------------------------------------------------------------
Total Number of data:        852.000
Number of valid data:        852.000
Minimum,50^ percentile,maximum :        48.2337       163.155       218.634
Mean and standard deviation    :       152.682       35.7344
-------------------------------------------------------------------------------

Figura 87 - Statistiche di una sezione verticale XZ di un campo3D, coordinata Y costante

-------------------------------------------------------------------------------
FILE: C:\SIMAGEPU\CATENA1\OUTPUT\conc_CATENA1_PU.bin
TIME SEQUENCE:     07/04/2004  15:00:00     
2D SCALAR FIELD: c_SO2
-------------------------------------------------------------------------------
Total Number of data:        3621.00
Number of valid data:        3621.00
Minimum,50^ percentile,maximum :        4.89575       6.32970       50.8450
Mean and standard deviation    :       6.85537       2.67998
-------------------------------------------------------------------------------

Figura 88 - File di statistiche di un campo 2D

6.4.2 File di tipo particle_NN.LOG

File generato ogniqualvolta viene richiesto un grafico di una sezione verticale XY o 2D, YZ, XZ con sovrapposizione delle particelle lette dal file di tipo PARTICLE.

Sequence number        1 Number of particle       22841
  Sequence number        1 Class        0 Plotted particles        15669
  Sequence number        1 Class        1 Plotted particles         3598
  Sequence number        1 Class        2 Plotted particles         1549
  Sequence number        1 Class        3 Plotted particles          677
  Sequence number        1 Class        4 Plotted particles          461
  Sequence number        1 Class        5 Plotted particles          334
  Sequence number        1 Class        6 Plotted particles          244
  Sequence number        1 Class        7 Plotted particles          308
  Sequence number        2 Number of particle       18671
  Sequence number        2 Class        0 Plotted particles         9725
  Sequence number        2 Class        1 Plotted particles         3660
  Sequence number        2 Class        2 Plotted particles         2081
  Sequence number        2 Class        3 Plotted particles         1289
  Sequence number        2 Class        4 Plotted particles          762
  Sequence number        2 Class        5 Plotted particles          437
  Sequence number        2 Class        6 Plotted particles          272
  Sequence number        2 Class        7 Plotted particles          432
  Sequence number        2 Class        8 Plotted particles            3
  Sequence number        2 Class        9 Plotted particles            4
  Total number of particles          41512
  Number of plotted particles        41505

Figura 89 – Esempio di file partic_NN.log

Le informazioni sono relative alle particelle plottate suddivise per sequenza temporale e per classe di colore.

Il contenuto di questo file viene aggiunto a quello delle statistiche statistic_NN.log, nella visualizzazione fatta con Image Info del menù contestuale (Par. 2.4.2).

6.4.3 statistic_DIAGONAL.log

Questo file viene generato ogniqualvolta si richiede un grafico con la funzione DIAGONAL. Non è visualizzabile tramite interfaccia grafica, ma è disponibile nella cartella di progetto.

-------------------------------------------------------------------------------
FILE: C:\User\dati\AOSTA\conc_c3d_08-110401
TIME SEQUENCE:     08/04/2001  01:00:00     
3D SCALAR FIELD: M001S001 - From [339.857,5051.43]  To [366.286,5080.86]
-------------------------------------------------------------------------------
Total Number of data:        177.000
Number of valid data:        177.000
Minimum,50^ percentile,maximum :       0.000000      0.000000       20.0802
Mean and standard deviation    :      0.293933       1.82467
-------------------------------------------------------------------------------

Figura 90 – Esempio di file statistic_DIAGONAL.log

Il contenuto è analogo a quello del file statistic_NN.log, non viene però visualizzato in nessun modo dall’interfaccia utente.

Appendice A - PV-WAVE Foundation

AVISU è stato scritto utilizzando il linguaggio grafico del package PV-WAVE, prodotto e venduto dalla società Visual Numerics™ Inc. e l’installazione di questi costituisce il prerequisito per il funzionamento di AVISU.

PV-WAVE è un prodotto soggetto a licenza ed inizialmente viene attivato con una licenza temporanea di tipo DEMO, con scadenza a tempo. Successivamente, per ottenere la licenza definitiva , l’utente deve lanciare una procedura inclusa nel pacchetto con la quale si genera un file che consente di richiedere la licenza definitiva: nella versione Windows, VNI rilascia una licenza per il singolo calcolatore su cui è stata fatta l’installazione e può essere di tipo FLOATING (per sviluppatori) o RUNTIME. In entrambi i casi la licenza ottenuta può essere condivisa tra più computer in rete locale, purché utilizzata da un solo calcolatore alla volta.

La licenza definitiva del package è gestita dal License Manager FLEXlm®

In questa appendice sono riassunte le diverse fasi di installazione di PV-WAVE e delle licenze temporanea e definitiva. Vengono inoltre date indicazioni su come effettuare test delle licenza e come risolvere eventuali problemi.

Le procedure qui elencate si riferiscono all’installazione della versione 9.0 di PV-WAVE, su piattaforma Windows, nella cartella predefinita C:\VNI. In fase di installazione è possibile cambiare cartella di destinazione, tuttavia è preferibile scegliere un dispositivo locale e un percorso che non contenga caratteri spazio.

In caso di diversa cartella di installazione, le citazioni ai percorsi dei file nei paragrafi successivi, devono tener conto di questa scelta.

A.1 Installazione

1. Inserire il CD. Se dopo alcuni istanti non compare la finestra di installazione, da Risorse del Computer, aprire l’unità corrispondente, esplorare il CD fino alla cartella bin_install\CDROM_Installers\ Disk1\Inst Dat \Windows\VM ed eseguire il file installa.exe.

2. Compare la finestra in Figura 91.

A_figura156.jpg

Figura 91 – Installazione di Pv-Wave. Introduction: finestra iniziale

3. Cliccare su Next e poi su "I accept the terms ..."

A_figura157.jpg

Figura 92 - License Agreement

4. Cliccare su Next, senza cambiare nulla, eventualmente cambiando la directory di installazione (C:\VNI) fino a che appare la schermata seguente:

A_figura158.jpg

Figura 93 - Pre-Installation Summary

5. Proseguire Con Install fino al completamento dell’installazione, ignorando eventuali messaggi di warning che dovessero apparire.

6. Terminata l’installazione, l’utente deve copiare il file di licenza temporanea license.lic in C:\VNI\LICENSE.

A.2 Test di PV-WAVE con licenza temporanea

Il package viene attivato inizialmente con una licenza temporanea, consistente in un file chiamato license.lic che deve essere posto dall’utente nella directory C:\VNI\license. La licenza è di tipo DEMO e non richiede l’attivazione del License Manager.

Il package PV-WAVE attivato in questa modalità è funzionalmente equivalente alla versione FLOATING, ma con scadenza a tempo, indicata nel file stesso.

Per verificare che il package funzioni correttamente, aprire la barra dei Programmi di Windows e selezionare il comando:

Programmi=>PV-WAVE9.0 Product Family=>PV-WAVE9.0=>PV-WAVE Home Window

Se il package è stato installato correttamente compare la finestra di Figura 94, in caso contrario viene visualizzata una finestra d’errore.

A_figura159.jpg

Figura 94 – Finestra “Home Window” di Pv-WAVE

A questo punto, se si preme il tasto F1, parte la demo di PV-WAVE (Figura 95), che permette all’utente di esplorare le diverse funzioni del package grafico.

A_figura160.jpg

Figura 95 - Finestra demo Pv-WAVE (F1)

Poiché la licenza temporanea scade alla data indicata nel file license.lic, per poter continuare ad usare AVISU, si dovrà procedere con la richiesta della licenza definitiva come descritto nel paragrafo successivo.

A.3 Come ottenere la licenza definitiva

La licenza definitiva viene rilasciata da VNI a seguito della spedizione di un file contenente le caratteristiche del PC su cui è stato installato il package. Per ootenere questo file, occorre aprire una finestra DOS con Programmi => Accessori => Prompt dei comandi ed eseguire i comandi seguenti:

cd /d C:\VNI\license\bin

get_hostid_Intel.bat C:\VNI

Dopo l’esecuzione di questa procedura, si ottiene il file C:\VNI\license\bin\hostinfo.<nome sistema>, che contiene il Nome del PC e l’Etichetta del disco C: che identificheranno in modo univoco la licenza. Questo file deve essere inviato a support@… per ottenere la licenza definitiva.

A.4 Installazione della licenza definitiva

Quando viene inviato all’utente il file di licenza definitiva, occorre prima di tutto preparare il file e poi eseguirne l’attivazione. Il file originale si presenta nella forma di Figura 96: nell’esempio WK_1345 è il Nome del PC e ab3f3e9c l’Etichetta del disco C:.

############# LICENSE FILE STARTS HERE ################# 
SERVER WK_1345 DISK_SERIAL_NUM=ab3f3e9c 27000 
DAEMON VNI /usr/local/vni/license/bin/VNI 
FEATURE RTWFOUNDATION VNI 9.00 01-jan-00 1 0DCFD212F950156296E9 
############## LICENSE FILE ENDS HERE ##################

Figura 96 – Esempio di file licenza rilasciato da VNI

La licenza verrà gestita dal License Manager FLEXlm® che interpreterà le tre righe che iniziano con SERVER, DAEMON e FEATURE: la prima riga identifica il PC, la seconda il percorso del file vni.exe e la terza il tipo di licenza e relativa scadenza. La data della riga FEATURE 01-jan-00 è simbolica ed indica che non esiste nessuna scadenza temporale del file.

A.4.1 Preparazione della licenza

  1. Salvare il file fornito con nome license.lic nella cartella C:\VNI\license, dove dovrebbe già trovarsi anche il file pack.lic.

Nota: Se Pv-Wave è stato installato in altro percorso, al posto di C:\VNI occorre mettere il path corretto.

  1. Editare il file license.lic per cambiare path della riga DAEMON, in modo da definire l’esatto percorso del file vni.exe:

DAEMON VNI C:\VNI\license\bin\bin.i386nt\vni.exe

A.4.2 Attivazione della licenza definitiva

Per l’attivazione della licenza occorre lanciare il programma C:\VNI\license\bin\bin.i386nt \lmtools.exe e compilare le schede come descritto nel seguito.

a) Scheda Service/ License File (Figura 97)

A_figura161.jpg

Figura 97 -LMTOOLS Manager

  • selezionare “Configuration using services”, ignorando il contenuto della sottostante finestra che mostra eventuali altri servizi attivi gestiti da FLEXlm®
  • abilitare il check box “LMTOOLS ignores license file path environment variables”

b) Scheda Config Services (Figura 98):

A_figura162.jpg

Figura 98 – LMTOOLS: Scheda Config Services

  • nella lista Service Name digitare “AVISU”;
  • nel campo Path to the lmgrd.exe file, usare il pulsante per navigare fino alla posizione del file lmgrd.exe;
  • nel campo Path to the license file, scrivere il nome della directory dove si trovano i file license.lic e pack.lic ;

Nota: non usare il pulsante Browse perché si aggiungerebbe anche un nome di file

  • nel campo Path to debug log file, scrivere il nome del file dove il License Manager FLEXLM scriverà i propri messaggi c:\VNI\licens \Debug.log;
  • attivare i check boxes “Start server at Power Up” e “Use Services”;
  • cliccare Save service per salvare i settaggi dati finora.

c) Scheda Start/ Stop/ Reread (Figura 99):

A_figura163.jpg

Figura 99 - LMTOOLS: Scheda Start/ Stop/ ReRead

  • selezionare il servizio appena creato e cliccare il pulsante “Start Server”: se il servizio parte correttamente nella riga di stato in fondo alla finestra compare la scritta “Server start successful”.In caso contrario ricontrollare i parametri della scheda Config Services e l’esistenza del file license.lic nella directory C:\VNI\license.

d) Scheda Server Status (Figura 100):

A_figura164.jpg

Figura 100 - LMTOOLS: Scheda Server Stat

  • cliccare il pulsante “Perform Status Enquiry” per verificare che il server della licenza sia funzionante.

e) Selezionare File => Exit per chiudere la finestra di LMTOOLS.

A.5 Utilizzo condiviso

La licenza di Pv-Wave per piattaforma Windows, viene rilasciata per un calcolatore identificato da Nome computer e Etichetta del relativo disco C: Per poter usare questa licenza, gli altri computer devono poter accedere a questo computer tramite il Nome ed essere e collegati alla stessa LAN. Una volta verificato questo, devono essere eseguita la procedura seguente:

  1. Installare Pv-Wave su tutti i PC in rete LAN su cui si vuole utilizzare la licenza (Par. A.1)
  1. Copiare il file license.lic della licenza definitiva (Par. A.4.1) nella directory C:\VNI\license di ciascun PC
  1. Attivare la licenza definitiva (Par.A.4.2) solo sul PC per cui è stata richiesta la licenza.

Il calcolatore su cui è installata la licenza farà da SERVER mentre tutti gli altri si configurano come CLIENT della licenza stessa. Ad ogni esecuzione di PV-WAVE, diretta o indiretta, fatta ad esempio eseguendo AVISU, su uno qualsiasi di questi PC, il SERVER darà il suo consenso (gettone) all’utilizzo del package soltanto se nessun’altro lo sta eseguendo. In caso contrario, sul PC che ne fa richiesta e non può ricevere il gettone, compare una segnalazione che avvisa l’utente che al momento la licenza è indisponibile e verrà messo inattesa.

A.6 Test della licenza definitiva

Se la licenza acquisita è di tipo FLOATING, la riga FEATURE del file license.lic contiene WFOUNDATION .

Nel caso invece la licenza sia di tipo RUNTIME, la riga FEATURE del file license.lic contiene RTWFOUNDATION.

Se la licenza è di tipo FLOATING, ripetere il test del Par. A.2. Nel caso la licenza sia di tipo RUNTIME, per testare che il tutto sia funzionante in ogni PC, provare ad eseguire la procedura <AVISU_DIR>\ pvtest_rt.bat. Dovrebbe apparire la finestra di Figura 101.

A_figura165.jpg

Figura 101 - Signal Processing Demonstration

Superato il test, per poter utilizzare AVISU, se la licenza è di tipo RUNTIME, occorre settare la variabile di ambiente VNI_RT come spiegato al paragrafo 0.

A.7 Risoluzione dei problemi

Se il test della licenza non ha avuto successo, al posto della Figura 101, viene visualizzato un messaggio d’errore. In questo caso possono verificarsi due condizioni: un problema dovuto al Firewall del SERVER (se PV-WAVE è installato in modalità condivisa) oppure il License Manager non gestisce correttamente la licenza. Se anche dopo la risoluzione dei problemi il test non viene superato, inviare una segnalazione d’errore a support@…, accompagnata in attachment dal file C:\VNI\license\Debug.log.

A.7.1 Errore dovuto a Firewall di Windows

Se l’errore si verifica su un CLIENT, che quindi utilizza la licenza Pv-Wave in rete (Par. A.5), potrebbe esistere un problema di Firewall del PC che fa da SERVER della licenza. In tal caso, su quest’ultimo, con il Firewall di Windows attivo, occorre abilitare l’input da due porte TCP usate da Pv-Wave.

Sulla macchina SERVER, aprire Windows Firewall:

- in scheda Generale, togliere il segno di spunta a “Non consentire eccezioni”, perché servono due nuove eccezioni che sono qui sotto riportate;

- in scheda Eccezioni, cliccare “Aggiungi Porta ...” e nella finestra dare

Nome VNI

Numero porta 1344

Tipo TCP

Cliccare su “OK” per terminare. Ripetere “Aggiungi Porta ...” e nella finestra dare

Nome LMGRD

Numero porta 27000

Tipo TCP

Cliccare su “OK” per terminare.

- a questo punto nella scheda Eccezioni, occorre attivare le due nuove eccezioni create, cliccando il checkbox a fianco del loro nome

- uscire da Eccezioni con “OK”.

Fatto ciò, sulle macchine CLIENT si può provare a far rigirare il test.

Errore dovuto al License Manager 1

Se il test non dovesse funzionare, come misura correttiva, si può accodare il file pack.lic al file license.lic. Questa operazione può essere effettuata con un text editor, facendo attenzione a che non vengano introdotte righe vuote fra il primo e il secondo file.

Il file così ottenuto dovrà chiamarsi ancora license.lic e sostituire il precedente nella cartella C:\VNI\license .

Se la licenza è stata installata su più PC, effettuare questa operazione sul PC di tipo SERVER e poi, eventualmente, anche sui CLIENT.

A.7.2 Errore dovuto al License Manager 2

Un’altro condizione che può generare errore è quella dovuta alla presenza di un’altro package gestito dallo stesso License Manager FLEXlm®. In tal caso potrebbe non funzionare, se esiste nel Registro di Windows la chiave LM_LICENSE_FILE e non contiene il percorso corretto dei entrambi i software. Si può provare allora a risolvere il problema modificando il Registro di Windows.

Cliccare su:

Barra delle Applicazioni => Start =>Esegui...

E scrivere il comando regedit, seguito da <Invio>. Si apre la finestra per l’editor del Registro di Window: trovare la chiave di registro LM_LICENSE_FILE e modificarne il valore in modo da aggiungere il percorso mancante.

Ad esempio:

LM_LICENSE_FILE=C:\VNI\license;C:\Program Files\MapInfo\Professional

Chiudere il programma regedit e provare di nuovo il test.

Appendice B - Impostazioni delle variabili di ambiente per AVISU

Il package AVISU, così come fornito con il CD di installazione, prevede che PV-WAVE sia stato installato nella directory C:\VNI e che la relativa licenza sia di tipo FLOATING o DEMO.

La licenza definitiva solitamente fornita con AVISU è invece di tipo RUNTIME e per questo motivo si richiede che, dopo l’installazione della licenza definitiva (A.4), l’utente introduca la variabile di ambiente VNI_RT per notificare il cambio di modalità.

Se inoltre, per qualche motivo, l’installazione di PV-WAVE è stata fatta in una directory diversa da quella di default C:\VNI, si può settare la variabile di ambiente VNI_DIR per tenerne conto. La configurazione di una o entrambe queste variabili deve essere eseguita dall’utente manualmente.

B.1 Configurazione di AVISU per licenza RUNTIME

Quando il file license.lic contiene la FEATURE RTWFOUNDATION, il package PV-WAVE è licenziato in modalità RUNTIME, quindi per il corretto funzionamento di AVISU, occorre aggiungere la variabile d’ambiente VNI_RT.

Aprire:

Impostazioni => Pannello di controllo => Sistema

Scegliere:

Avanzate => Variabili di ambiente …

Nella sezione Variabili di sistema, aggiungere con Nuovo… la variabile VNI_RT e assegnarle il valore RUNTIME.

Premere OK fino alla chiusura della finestra Proprietà del sistema.

B.2 Installazione PV-WAVE in percorso diverso da C:\VNI

Se il package PV-WAVE è stato installato in una directory diversa da quella di default C:\VNI, per il corretto funzionamento di AVISU, occorre aggiungere la variabile d’ambiente VNI_DIR.

Aprire:

Impostazioni => Pannello di controllo => Sistema

Scegliere:

Avanzate => Variabili di ambiente …

Nella sezione Variabili di sistema, aggiungere con Nuovo… la variabile VNI_DIR e assegnarle il valore <VNI>, dove <VNI> è la directory di installazione di PV-WAVE (ad esempio C:\Programmi\VNI).

Premere OK fino alla chiusura della finestra Proprietà del sistema.

Attachments (1)

Download all attachments as: .zip